Head, Board, Whack

In my ongoing quest to resolve the problem of my runaway osascript, I thought I’d look into Apple’s support site — maybe someone else has run into the same problem. This morning, after all, I came to the computer I had put to sleep last night, and found it awake, warm, and running at 50% processor load. Something, presumably, had triggered the script during the night (glad it was sitting open rather than closed).
 
So at the Apple Support site, I entered “osascript” in the search window, and the search returned results for the word “osa.” Tried it again — maybe some helpful widget was jumping in and searching for “osa” as a shortcut — same result. Apple Supprt evidently won’t search for the string “script.” Tried “Applescript,” to check — same result. I infer that this is a sort of defense against malicious searches that might try to execute scripts that would hack into their server system. [OK, solved that: I was typing into the main search window, not a “Support”-specific search window. My bad. Still, the Support search yields very few results, most oriented toward working with Apple Remote Desktop.]
 
At last! I found my way to the support forum that deals with AppleScript, posted my query, and an hour or so later was rewarded with a response that suggested a Terminal command [ps -axwj] that would identify the source of the script that was plaguing me. I tried it, and sure enough, it gave a much fuler account of the parent processes and the source of the offending script. In my case, JunkMatcher had developed a hyperbolic interest in combing my mail for possible junk, and I quickly disabled the script in the “Rules” portion of Mail.app, and threw out the scripts from my user library. EVerything has been calm since then; I think we have a winner.

1 comment / Add your comment below

Leave a Reply

Your email address will not be published. Required fields are marked *